#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^someFunction\(\{(?:\n(?!(?: +message:|}\))).*)*\n +message:(.*)\n}\)$"
Local $sString = "someFunction({" & @CRLF & _
" a: true," & @CRLF & _
" b: false" & @CRLF & _
"})" & @CRLF & _
"someFunction({" & @CRLF & _
" a: true," & @CRLF & _
" b: false," & @CRLF & _
" c: false," & @CRLF & _
" d: true," & @CRLF & _
" message: 'I wnat to find the funciton with this property'" & @CRLF & _
"})" & @CRLF & _
"someFunction({" & @CRLF & _
" a: true" & @CRLF & _
"})" & @CRLF & _
"" & @CRLF & _
"someFunction({" & @CRLF & _
" a: true," & @CRLF & _
" b: false" & @CRLF & _
"})" & @CRLF & _
"someFunction({" & @CRLF & _
" a: true," & @CRLF & _
" b: false," & @CRLF & _
" c: false," & @CRLF & _
" d: true," & @CRLF & _
" message: 'I wnat to find the funciton with this property'" & @CRLF & _
"})" & @CRLF & _
"someFunction({" & @CRLF & _
" a: true" & @CRLF & _
"})"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")