import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^someFunction\\(\\{(?:\\n(?!(?: +message:|\\}\\))).*)*\\n +message:(.*)\\n\\}\\)$";
final String string = "someFunction({\n"
+ " a: true,\n"
+ " b: false\n"
+ "})\n"
+ "someFunction({\n"
+ " a: true,\n"
+ " b: false,\n"
+ " c: false,\n"
+ " d: true,\n"
+ " message: 'I wnat to find the funciton with this property'\n"
+ "})\n"
+ "someFunction({\n"
+ " a: true\n"
+ "})\n\n"
+ "someFunction({\n"
+ " a: true,\n"
+ " b: false\n"
+ "})\n"
+ "someFunction({\n"
+ " a: true,\n"
+ " b: false,\n"
+ " c: false,\n"
+ " d: true,\n"
+ " message: 'I wnat to find the funciton with this property'\n"
+ "})\n"
+ "someFunction({\n"
+ " a: true\n"
+ "})";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}