re = /^someFunction\(\{(?:\n(?!(?: +message:|}\))).*)*\n +message:(.*)\n}\)$/m
str = 'someFunction({
a: true,
b: false
})
someFunction({
a: true,
b: false,
c: false,
d: true,
message: \'I wnat to find the funciton with this property\'
})
someFunction({
a: true
})
someFunction({
a: true,
b: false
})
someFunction({
a: true,
b: false,
c: false,
d: true,
message: \'I wnat to find the funciton with this property\'
})
someFunction({
a: true
})'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end