#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([A-Za-z]{2}[0-9*]{0,6}|\*)$"
Local $sString = "RIGHT:" & @CRLF & _
"*" & @CRLF & _
"DE*" & @CRLF & _
"de*" & @CRLF & _
"GB5*" & @CRLF & _
"gb5*" & @CRLF & _
"DE*123" & @CRLF & _
"DE**123" & @CRLF & _
"de*123" & @CRLF & _
"DE123456" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"WRONG:" & @CRLF & _
"**" & @CRLF & _
"*DE" & @CRLF & _
"*de" & @CRLF & _
"D" & @CRLF & _
"D*" & @CRLF & _
"D**" & @CRLF & _
"d*" & @CRLF & _
"DE" & @CRLF & _
"DE123" & @CRLF & _
"DE123**" & @CRLF & _
"de" & @CRLF & _
"D1*" & @CRLF & _
"1" & @CRLF & _
"1*" & @CRLF & _
"123*" & @CRLF & _
"1234" & @CRLF & _
"DE1234567" & @CRLF & _
"DE123456*"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")