// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([A-Za-z]{2}[0-9*]{0,6}|\*)$").unwrap();
let string = "RIGHT:
*
DE*
de*
GB5*
gb5*
DE*123
DE**123
de*123
DE123456
WRONG:
**
*DE
*de
D
D*
D**
d*
DE
DE123
DE123**
de
D1*
1
1*
123*
1234
DE1234567
DE123456*";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}