import re
regex = re.compile(r"^([A-Za-z]{2}[0-9*]{0,6}|\*)$", flags=re.MULTILINE)
test_str = ("RIGHT:\n"
"*\n"
"DE*\n"
"de*\n"
"GB5*\n"
"gb5*\n"
"DE*123\n"
"DE**123\n"
"de*123\n"
"DE123456\n\n\n"
"WRONG:\n"
"**\n"
"*DE\n"
"*de\n"
"D\n"
"D*\n"
"D**\n"
"d*\n"
"DE\n"
"DE123\n"
"DE123**\n"
"de\n"
"D1*\n"
"1\n"
"1*\n"
"123*\n"
"1234\n"
"DE1234567\n"
"DE123456*")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")