#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?![^\{]*\})use\s+(?![^{]*\})"
Local $sString = "use Package;" & @CRLF & _
"use Package2;" & @CRLF & _
"" & @CRLF & _
"class {" & @CRLF & _
" use Trait;" & @CRLF & _
"" & @CRLF & _
" function fn() {" & @CRLF & _
" function () use ( $var ) {" & @CRLF & _
"" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")