$re = '/(?![^\{]*\})use\s+(?![^{]*\})/m';
$str = 'use Package;
use Package2;
class {
use Trait;
function fn() {
function () use ( $var ) {
}
}
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);