import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?![^\\{]*\\})use\\s+(?![^\\{]*\\})";
final String string = "use Package;\n"
+ "use Package2;\n\n"
+ "class {\n"
+ " use Trait;\n\n"
+ " function fn() {\n"
+ " function () use ( $var ) {\n\n"
+ " }\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}