#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((((([1-9][0-9]((0[48])|([13579][26])|([2468][048])))|(([1-9]((0[48])|([13579][26])|([2468][048]))))|(([13579][26])|([2468][048]))|([48]))|(((([13579][26])|([2468][048]))|[48])00))\/2\/(([1-9])|(1[0-9])|([2][0-9])))|(([1-9][0-9]{0,3})\/((([13578]|1[02])\/([1-9]|[12][0-9]|3[01]))|((([469]|11)\/([1-9]|([12][0-9])|(30)))|(2\/(([1-9])|(1[0-9])|([2][0-8]))))))) ((([02468])|([1][02468])|(2[02])):00)"
Local $sString = "判断时间的合法性" & @CRLF & _
"PTA作业链接" & @CRLF & _
"https://pintia.cn/problem-sets/1244999401232809984/problems/1245332988779970560" & @CRLF & _
"题目要求链接" & @CRLF & _
"https://images.ptausercontent.com/218e185f-05fe-4a17-be9b-640b21b74373.pdf" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"2015/8/5 2:00" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")