import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((((([1-9][0-9]((0[48])|([13579][26])|([2468][048])))|(([1-9]((0[48])|([13579][26])|([2468][048]))))|(([13579][26])|([2468][048]))|([48]))|(((([13579][26])|([2468][048]))|[48])00))\\/2\\/(([1-9])|(1[0-9])|([2][0-9])))|(([1-9][0-9]{0,3})\\/((([13578]|1[02])\\/([1-9]|[12][0-9]|3[01]))|((([469]|11)\\/([1-9]|([12][0-9])|(30)))|(2\\/(([1-9])|(1[0-9])|([2][0-8]))))))) ((([02468])|([1][02468])|(2[02])):00)";
final String string = "判断时间的合法性\n"
+ "PTA作业链接\n"
+ "https://pintia.cn/problem-sets/1244999401232809984/problems/1245332988779970560\n"
+ "题目要求链接\n"
+ "https://images.ptausercontent.com/218e185f-05fe-4a17-be9b-640b21b74373.pdf\n\n\n"
+ "2015/8/5 2:00\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}