// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((((([1-9][0-9]((0[48])|([13579][26])|([2468][048])))|(([1-9]((0[48])|([13579][26])|([2468][048]))))|(([13579][26])|([2468][048]))|([48]))|(((([13579][26])|([2468][048]))|[48])00))\/2\/(([1-9])|(1[0-9])|([2][0-9])))|(([1-9][0-9]{0,3})\/((([13578]|1[02])\/([1-9]|[12][0-9]|3[01]))|((([469]|11)\/([1-9]|([12][0-9])|(30)))|(2\/(([1-9])|(1[0-9])|([2][0-8]))))))) ((([02468])|([1][02468])|(2[02])):00)").unwrap();
let string = "判断时间的合法性
PTA作业链接
https://pintia.cn/problem-sets/1244999401232809984/problems/1245332988779970560
题目要求链接
https://images.ptausercontent.com/218e185f-05fe-4a17-be9b-640b21b74373.pdf
2015/8/5 2:00
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}