#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)interface (\S+)[^!]+?access-session port-control force-authorized"
Local $sString = "interface GigabitEthernet1/0/44 " & @CRLF & _
"access-session port-control auto " & @CRLF & _
"!" & @CRLF & _
"interface GigabitEthernet1/0/45 " & @CRLF & _
"access-session port-control force-authorized " & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")