$re = '/interface (\S+)[^!]+?access-session port-control force-authorized/i';
$str = 'interface GigabitEthernet1/0/44
access-session port-control auto
!
interface GigabitEthernet1/0/45
access-session port-control force-authorized
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);