package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(http|https):\/\/[\w\-_]+(\.[\w\-_]+)+[\w\-\.,@?^=%&:\/~\+#]*[\w\-\@?^=%&\/~\+#]`)
var str = `This is https://www.example.com/an-example-url and http://www.example.com/and-some-friendlyurl?utm_campaign=test&id=4 .<br/>.Themes.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}