$re = '/(http|https):\/\/[\w\-_]+(\.[\w\-_]+)+[\w\-\.,@?^=%&:\/~\+#]*[\w\-\@?^=%&\/~\+#]/';
$str = 'This is https://www.example.com/an-example-url and http://www.example.com/and-some-friendlyurl?utm_campaign=test&id=4 .<br/>.Themes.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);