re = /(http|https):\/\/[\w\-_]+(\.[\w\-_]+)+[\w\-\.,@?^=%&:\/~\+#]*[\w\-\@?^=%&\/~\+#]/
str = 'This is https://www.example.com/an-example-url and http://www.example.com/and-some-friendlyurl?utm_campaign=test&id=4 .<br/>.Themes.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end