package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(develop|main)?$|^(bug|feature|hotfix)\/[a-z0-9]+(-[a-z0-9]+)*(-[0-9]+)?$`)
var str = `main`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}