$re = '/^(develop|main)?$|^(bug|feature|hotfix)\/[a-z0-9]+(-[a-z0-9]+)*(-[0-9]+)?$/m';
$str = 'main';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);