re = /^(develop|main)?$|^(bug|feature|hotfix)\/[a-z0-9]+(-[a-z0-9]+)*(-[0-9]+)?$/m
str = 'main'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end