import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)(?!=\\S*[_.:;\\-\\\\\\/@+*]{2})(?=[^\\d\\s]*\\d)[\\w.:;\\-\\\\\\/@+*]+(?!\\S)";
final String string = "ajh12-&\n"
+ "671%&i^\n\n"
+ "165271 123\n"
+ "agya678\n"
+ "yah@123\n"
+ "kj*12-";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}