$re = '/(?<!\S)(?!=\S*[_.:;\-\\\\\/@+*]{2})(?=[^\d\s]*\d)[\w.:;\-\\\\\/@+*]+(?!\S)/m';
$str = 'ajh12-&
671%&i^
165271 123
agya678
yah@123
kj*12-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);