re = /(?<!\S)(?!=\S*[_.:;\-\\\/@+*]{2})(?=[^\d\s]*\d)[\w.:;\-\\\/@+*]+(?!\S)/m
str = 'ajh12-&
671%&i^
165271 123
agya678
yah@123
kj*12-'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end