using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Instrument\=\\\""(?<Instrument>\w+)";
string input = @"< Instrument=\""Guitar\"" Price=\""500\"" >";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}