package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Instrument\=\\\"(?<Instrument>\w+)`)
var str = `< Instrument=\"Guitar\" Price=\"500\" >`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}