re = /Instrument\=\\\"(?<Instrument>\w+)/m
str = '< Instrument=\\"Guitar\\" Price=\\"500\\" >'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end