# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\[SM_g])([^[]*)(\[SM_h])((?=([,\.])|(\[SM_l])|( ?&\\?quot;)).*)?/\1\2\7\3/gm;t' <<< "[SM_g]word[SM_h].[SM_l] "
[SM_g]word[SM_h][SM_l]"
[SM_g]word[SM_h]"[SM_l].
[SM_g]word[SM_h]".
[SM_g]word[SM_h][SM_l].
[SM_g]word[SM_h].
[SM_g]word[SM_h]
[SM_g]word[SM_h] ".
[SM_g]word[SM_h][SM_l] &\quot;.
[SM_g]word[SM_h].[SM_l]"
[SM_g]word[SM_h]"[SM_l].
[SM_g]word[SM_h] "."