use strict;
my $str = '[SM_g]word[SM_h].[SM_l] "
[SM_g]word[SM_h][SM_l]"
[SM_g]word[SM_h]"[SM_l].
[SM_g]word[SM_h]".
[SM_g]word[SM_h][SM_l].
[SM_g]word[SM_h].
[SM_g]word[SM_h]
[SM_g]word[SM_h] ".
[SM_g]word[SM_h][SM_l] &\\quot;.
[SM_g]word[SM_h].[SM_l]"
[SM_g]word[SM_h]"[SM_l].
[SM_g]word[SM_h] ".';
my $regex = qr/(\[SM_g])([^[]*)(\[SM_h])((?=([,\.])|(\[SM_l])|( ?&\\?quot;)).*)?/mp;
my $subst = '\\1\\2\\7\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";