import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\[SM_g])([^[]*)(\\[SM_h])((?=([,\\.])|(\\[SM_l])|( ?&\\\\?quot;)).*)?";
final String string = "[SM_g]word[SM_h].[SM_l] "\n"
+ "[SM_g]word[SM_h][SM_l]"\n"
+ "[SM_g]word[SM_h]"[SM_l].\n"
+ "[SM_g]word[SM_h]".\n"
+ "[SM_g]word[SM_h][SM_l].\n"
+ "[SM_g]word[SM_h].\n"
+ "[SM_g]word[SM_h]\n"
+ "[SM_g]word[SM_h] ".\n"
+ "[SM_g]word[SM_h][SM_l] &\\quot;.\n\n"
+ "[SM_g]word[SM_h].[SM_l]"\n"
+ "[SM_g]word[SM_h]"[SM_l].\n\n\n"
+ "[SM_g]word[SM_h] ".";
final String subst = "\\1\\2\\7\\3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}