using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)\s+(?=[^()]*(\([^()]*(?1)?[^()]*\))*[^()]*$)";
string input = @"aa b+b cc(dd! :(ee ((f(f g)g)) h)h) ii ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}