re = /(?m)\s+(?=[^()]*(\([^()]*(?1)?[^()]*\))*[^()]*$)/
str = 'aa b+b cc(dd! :(ee ((f(f g)g)) h)h) ii '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end