using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<[\w:]+(?=\s)(?=(?:[^>""']|""[^""]*""|'[^']*')*?\shref\s*=\s*(?:(['""])(?:(?!\1|login)[\S\s])*\1))\s+(?:""[\S\s]*?""|'[\S\s]*?'|[^>]*?)+>";
string input = @"This is some a string <a href=""http://www.google.com"">google</a> and this is another that should not be found <a href=""https://www.google.com/login"">login</a>`
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}