import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<[\\w:]+(?=\\s)(?=(?:[^>\"']|\"[^\"]*\"|'[^']*')*?\\shref\\s*=\\s*(?:(['\"])(?:(?!\\1|login)[\\S\\s])*\\1))\\s+(?:\"[\\S\\s]*?\"|'[\\S\\s]*?'|[^>]*?)+>";
final String string = "This is some a string <a href=\"http://www.google.com\">google</a> and this is another that should not be found <a href=\"https://www.google.com/login\">login</a>`\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}