import re
regex = re.compile(r"<[\w:]+(?=\s)(?=(?:[^>\"']|\"[^\"]*\"|'[^']*')*?\shref\s*=\s*(?:(['\"])(?:(?!\1|login)[\S\s])*\1))\s+(?:\"[\S\s]*?\"|'[\S\s]*?'|[^>]*?)+>")
test_str = ("This is some a string <a href=\"http://www.google.com\">google</a> and this is another that should not be found <a href=\"https://www.google.com/login\">login</a>`\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")