$re = '/(.)_\1/m';
$str = '_AA_AA_AA_BB_BB_CC';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;