import re
regex = re.compile(r"(.)_\1", flags=re.MULTILINE)
test_str = "_AA_AA_AA_BB_BB_CC"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)