#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)\bDresden(?:[.,]|\s+)?(.*)"
Local $sString = "Sächsischer Landtag DRUCKSACHE , 1972" & @CRLF & _
"2. Wahlperiode" & @CRLF & _
"" & @CRLF & _
"Kleine Anfrage" & @CRLF & _
"" & @CRLF & _
"der Abgeordneten Brigitte Zschoche" & @CRLF & _
"PDS-Fraktion" & @CRLF & _
"" & @CRLF & _
"Thema: Zuständigkeiten der Staatsministerin für Fragen der Gleichstellung" & @CRLF & _
"von Frau und Mann" & @CRLF & _
"" & @CRLF & _
"Frage an die Staatsregierung:" & @CRLF & _
"1. In welcher Art und Weise versteht die Staatsministerin ihr Amt als eine Querschnittsaufgabe?" & @CRLF & _
"" & @CRLF & _
"2. Inwieweit und mit welchen Befugnissen seitens der Staatsministerin erfolgt eine Koordinierung" & @CRLF & _
"der Frauenpolitik und konkrete Abstimmung in Angelegenheiten mit frauenpolitischem Bezug" & @CRLF & _
"zwischen den einzelnen Staatsministerien und der Staatsministerin?" & @CRLF & _
"" & @CRLF & _
"3. In welcher Art und Weise wurde die Staatsministerin an der Erarbeitung der im EPL 02" & @CRLF & _
"verankerten gleichstellungsrelevanten Haushaltsansätzen beteiligt?" & @CRLF & _
"" & @CRLF & _
"4. Inwieweit hat die Staatsministerin für Frau und Mann am arbeitsmarktpolitischen Programm" & @CRLF & _
""Arbeit und Qualifizierung für Sachsen” mitgewirkt?" & @CRLF & _
"" & @CRLF & _
"5. Hält es die Staatsministerin nach einem Jahr Erfahrungen in ihrem Amt für angemessen, erneut" & @CRLF & _
"" & @CRLF & _
"über die Einrichtung eines selbständigen Gleichstellungsministerium mit dementsprechendem" & @CRLF & _
"Etat nachzudenken?" & @CRLF & _
"" & @CRLF & _
"b cla" & @CRLF & _
"" & @CRLF & _
"Brigitte Zschoche" & @CRLF & _
"MdL Dresden, den 17.10.1995" & @CRLF & _
"" & @CRLF & _
"Eingegangen am: 18.10.1995 Ausgegeben-am:..........." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")