import Foundation
let pattern = #"\bDresden(?:[.,]|\s+)?(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
Sächsischer Landtag DRUCKSACHE , 1972
2. Wahlperiode
Kleine Anfrage
der Abgeordneten Brigitte Zschoche
PDS-Fraktion
Thema: Zuständigkeiten der Staatsministerin für Fragen der Gleichstellung
von Frau und Mann
Frage an die Staatsregierung:
1. In welcher Art und Weise versteht die Staatsministerin ihr Amt als eine Querschnittsaufgabe?
2. Inwieweit und mit welchen Befugnissen seitens der Staatsministerin erfolgt eine Koordinierung
der Frauenpolitik und konkrete Abstimmung in Angelegenheiten mit frauenpolitischem Bezug
zwischen den einzelnen Staatsministerien und der Staatsministerin?
3. In welcher Art und Weise wurde die Staatsministerin an der Erarbeitung der im EPL 02
verankerten gleichstellungsrelevanten Haushaltsansätzen beteiligt?
4. Inwieweit hat die Staatsministerin für Frau und Mann am arbeitsmarktpolitischen Programm
"Arbeit und Qualifizierung für Sachsen” mitgewirkt?
5. Hält es die Staatsministerin nach einem Jahr Erfahrungen in ihrem Amt für angemessen, erneut
über die Einrichtung eines selbständigen Gleichstellungsministerium mit dementsprechendem
Etat nachzudenken?
b cla
Brigitte Zschoche
MdL Dresden, den 17.10.1995
Eingegangen am: 18.10.1995 Ausgegeben-am:...........
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)