# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\bDresden(?:[.,]|\s+)?(.*)"
test_str = ("Sächsischer Landtag DRUCKSACHE , 1972\n"
"2. Wahlperiode\n\n"
"Kleine Anfrage\n\n"
"der Abgeordneten Brigitte Zschoche\n"
"PDS-Fraktion\n\n"
"Thema: Zuständigkeiten der Staatsministerin für Fragen der Gleichstellung\n"
"von Frau und Mann\n\n"
"Frage an die Staatsregierung:\n"
"1. In welcher Art und Weise versteht die Staatsministerin ihr Amt als eine Querschnittsaufgabe?\n\n"
"2. Inwieweit und mit welchen Befugnissen seitens der Staatsministerin erfolgt eine Koordinierung\n"
"der Frauenpolitik und konkrete Abstimmung in Angelegenheiten mit frauenpolitischem Bezug\n"
"zwischen den einzelnen Staatsministerien und der Staatsministerin?\n\n"
"3. In welcher Art und Weise wurde die Staatsministerin an der Erarbeitung der im EPL 02\n"
"verankerten gleichstellungsrelevanten Haushaltsansätzen beteiligt?\n\n"
"4. Inwieweit hat die Staatsministerin für Frau und Mann am arbeitsmarktpolitischen Programm\n"
"\"Arbeit und Qualifizierung für Sachsen” mitgewirkt?\n\n"
"5. Hält es die Staatsministerin nach einem Jahr Erfahrungen in ihrem Amt für angemessen, erneut\n\n"
"über die Einrichtung eines selbständigen Gleichstellungsministerium mit dementsprechendem\n"
"Etat nachzudenken?\n\n"
"b cla\n\n"
"Brigitte Zschoche\n"
"MdL Dresden, den 17.10.1995\n\n"
"Eingegangen am: 18.10.1995 Ausgegeben-am:...........\n"
"")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.