package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)'([^']+)':\(`)
var str = `'hello there':(
'more text':(
'she said \'hello\'':( <-- will not work, see Assumption 1
'hello' enough? :( <-- will not work, see Assumption 2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}