re = /'([^']+)':\(/m
str = '\'hello there\':(
\'more text\':(
\'she said \\\'hello\\\'\':( <-- will not work, see Assumption 1
\'hello\' enough? :( <-- will not work, see Assumption 2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end