using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[[^\/]+(.+)\/[3-9]\d\d\-";
string input = @"/item/708-furfural-chemical-building-block
/item/645-furfural-derivatives-in-apple-cider-and-win";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}