package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[[^\/]+(.+)\/[3-9]\d\d\-`)
var str = `/item/708-furfural-chemical-building-block
/item/645-furfural-derivatives-in-apple-cider-and-win`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}