re = /[[^\/]+(.+)\/[3-9]\d\d\-/m
str = '/item/708-furfural-chemical-building-block
/item/645-furfural-derivatives-in-apple-cider-and-win'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end