use strict;
my $str = 'dotproperty/email/send-alert-interest
dotproperty/email/send-alert
dotproperty/email/enquiry
dotproperty/email/click-to-call-property
dotproperty/email/registration
dotproperty/email/follow-up
dotproperty/email/agent-enquiry
dotproperty/email/created-alert
dotproperty/email/loan-cal-onpage
dotproperty/email/property-shared
dotproperty/email/remind-agent';
my $regex = qr/^dotproperty\/email(?!.*(send-alert-interest|enquiry|click-to-call-property|registration|follow-up|created-alert|loan-cal-onpage|property-shared|remind-agent))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}