# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^dotproperty\/email(?!.*(send-alert-interest|enquiry|click-to-call-property|registration|follow-up|created-alert|loan-cal-onpage|property-shared|remind-agent))"
test_str = ("dotproperty/email/send-alert-interest\n"
"dotproperty/email/send-alert\n"
"dotproperty/email/enquiry\n"
"dotproperty/email/click-to-call-property\n"
"dotproperty/email/registration\n"
"dotproperty/email/follow-up\n"
"dotproperty/email/agent-enquiry\n"
"dotproperty/email/created-alert\n"
"dotproperty/email/loan-cal-onpage\n"
"dotproperty/email/property-shared\n"
"dotproperty/email/remind-agent")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.