$re = '/^dotproperty\/email(?!.*(send-alert-interest|enquiry|click-to-call-property|registration|follow-up|created-alert|loan-cal-onpage|property-shared|remind-agent))/m';
$str = 'dotproperty/email/send-alert-interest
dotproperty/email/send-alert
dotproperty/email/enquiry
dotproperty/email/click-to-call-property
dotproperty/email/registration
dotproperty/email/follow-up
dotproperty/email/agent-enquiry
dotproperty/email/created-alert
dotproperty/email/loan-cal-onpage
dotproperty/email/property-shared
dotproperty/email/remind-agent';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);