use strict;
my $str = 'Example 1: bla bla bla
Example 2: bla bla ERROR
Example 3: bla bla
Example 4: bla bla ERROR bla bla';
my $regex = qr/Example\s+(\d+):(?:.*?(ERROR)|.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}