re = /Example\s+(\d+):(?:.*?(ERROR)|.*)/m
str = 'Example 1: bla bla bla
Example 2: bla bla ERROR
Example 3: bla bla
Example 4: bla bla ERROR bla bla'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end