# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\D//gm;t' <<< "/Date(123456789)/
Agora não considera mais esses caracteres: []^\_
e só deixa os números: 1234 567"